Python 2.7:今天起正式停用!

如果你在使用Python 2.7,应该考虑将编写的脚本迁移到Python 3.x。

/uploads/fox/03112358_0.jpeg
Python 2.7在进入2020年后将不再得到维护。

起初,官方并没有给出具体的日期表明何时停用Python 2.7。最近,停用日期已更新为2020年1月1日。

Python 2,谢谢你这么多年来提供的忠诚服务。
Python 3,现在该你上场了。
大问题:Python 3并不向后兼容。

这通常是一件好事。Python 3纠正了该编程语言中的一些根本性的设计缺陷和冗余之处,这应该会带来更简洁、更优雅的代码。但这也意味着Python 2.x代码并不自动与Python 3兼容。

该如何开始入手?

如果你在乎的代码仍使用Python 2,这完全可以理解。PyPI的流行软件包大多数现在使用Python 2和3,如今每天更多的软件包在不断添加中。另外,许多重大的Python项目郑重承诺很快停止支持Python 2。
 
为了使过渡更顺畅,官方移植指南(https://docs.python.org/3/howto/pyporting.html)给出了建议,帮助用户将Python 2代码移植到Python 3。

就因为Python 2.7在进入2020年后不再得到维护并不意味着你的应用程序或代码库会突然停止运行。如果你的项目很稳定很可靠,又没有任何安全方面的问题,何必修复并没有坏掉的系统?
 
你甚至可以同时拥有Python 2项目和Python 3项目,并在不同的.conda环境中轻松管理它们。

扫一扫,在手机阅读、分享本文

0
分享 2020-01-03

0 个评论

要回复文章请先登录注册